Leggi gli ultimi interventi sul forum
 
You are here: Sky ForumHardwareComputerPortatiliDell Studio 1557
: [1] 2
Dell Studio 1557
Dell Studio 1557
« : November 12, 2009, 11:07:56 pm »

Salve,
ho acquistato un Dell Studio 1557 e ho problemi con ubuntu (il problema persiste sia in jaunty che karmic):
i pulsanti della luminosità funzionano, solo che non appare nessuna notifica mentre se clicco sui tasti del volume, esso si azzera e poi la notifica inizia a lampeggiare all'impazzata disattivando i controlli della tastiera e cliccando su, ad esempio, Applicazioni, non appare nulla nel menu...

Inoltre non riesco a riprodurre i DVD Criptati (anche con libdvdcss, io ho il lettore/masterizzatore blu ray). Cambiando la regione del lettore ( regione 2 ), vlc apre il disco ma esso si vede male e poi crasha...
  • Wolf
  • ingegno
  • user
  • *
  • Offline Offline
  • : 70
  •  
Re: Dell Studio 1557
« #1 : November 13, 2009, 01:25:38 pm »

Ho trovato qualcosa in questo post.
Il problema dei tasti volume (come indica post) è già noto e segnalato quì.
Prova guardare nel wiki di ubuntu e a googlare un po' riguardo hotkey-setup ed udev (udev-extras, se non ricordo male, è stato accorpato).
E ricorda: ratio Google imperat!  :D
Re: Dell Studio 1557
« #2 : November 13, 2009, 05:34:13 pm »

Si avevo letto anche io quel post...
Si è capito che è un bug di ubuntu, ora devo risolvere il problema dei dvd criptati che non riesco propio a capire...
Re: Dell Studio 1557
« #3 : November 13, 2009, 07:35:41 pm »

Risolto per il problema del DVD! È bastato cancellare la cartella .dvdcss dalla mia home ed è andato!
Peccato per i tasti funzione...
Re: Dell Studio 1557
« #4 : November 14, 2009, 01:15:31 am »

Ti consiglio vivamente di provarci anche Fedora. Ci sono decine di cose per cui è preferibile in quanto a stabilità. Karmic è una versione beta e lo sarà ancora per qualche mese.
Re: Dell Studio 1557
« #5 : November 14, 2009, 11:01:09 am »

Secondo me è un problema di driver ATI. Quando vedo un DVD è come se non fosse selezionata l'opzione Sync to VBlank di Compiz... eppure è selezionata!
Qualcuno ha più esperienza con questi drivers?

EDIT: Ho provato Fedora, ma ha gli stessi bug di Ubuntu anzi non mi funziona il click sul touchpad...
« : November 14, 2009, 12:07:09 pm Reloweb »

Re: Dell Studio 1557
« #6 : November 14, 2009, 02:23:04 pm »

Risolto un problema di lag alla massimazione delle finestre con compiz attivo:
http://art.ubuntuforums.org/showthread.php?t=1107559&page=2
Re: Dell Studio 1557
« #7 : November 15, 2009, 06:19:24 pm »

Oltre al problema dei tasti funzione che abbiamo capito sia un problema del kernel, mi rimane da scoprire come attivare il vsync sotto i driver ATI.
Disattivando compiz i filmati sfarfallano peggio di quando è attivato quindi è sicuramente un problema di scheda grafica. Dal pannellino Catalyst pur attivando il vsync non si notano cambiamenti.
Ho cercato da tutte le parti ma niente da fare...
Re: Dell Studio 1557
« #8 : November 16, 2009, 11:29:16 am »

Oltre al problema dei tasti funzione che abbiamo capito sia un problema del kernel, mi rimane da scoprire come attivare il vsync sotto i driver ATI.
Disattivando compiz i filmati sfarfallano peggio di quando è attivato quindi è sicuramente un problema di scheda grafica. Dal pannellino Catalyst pur attivando il vsync non si notano cambiamenti.
Ho cercato da tutte le parti ma niente da fare...

Per quanto riguarda il supporto dei catalyst e dei moduli del kernel è tutto legato allo sviluppo e alle versioni del kernel stesso. Prova con versioni nuove del kernel e confronta le varie distribuzioni per sapere quale di esse adotti il kernel più aggiornato. Dovresti riuscire a risolvere.

Per il vsync prova anche a modificare il tuo Xorg.conf nella sezione device inserendo:

Code: [Select]
Option "TexturedVideoSync" "on"
poi vai su una console testo [CTRL+ALT+F1] e dai i seguenti comandi:

Code: [Select]
# invoke-rc.d gdm stop
# aticonfig --sync-vsync=on
# aticonfig --sync-video=on
# invoke-rc.d gdm restart
Re: Dell Studio 1557
« #9 : November 16, 2009, 01:40:30 pm »

Questo è il mio xorg.conf:
Code: [Select]
Section "ServerLayout"
Identifier     "amdcccle Layout"
Screen      0  "amdcccle-Screen[2]-0" 0 0
EndSection

Section "Files"
EndSection

Section "Module"
Load  "glx"
EndSection

Section "Monitor"
Identifier   "0-LCD"
Option     "VendorName" "ATI Proprietary Driver"
Option     "ModelName" "Generic Autodetecting Monitor"
Option     "DPMS" "true"
Option     "PreferredMode" "1920x1080"
Option     "TargetRefresh" "60"
Option     "Position" "0 0"
Option     "Rotate" "normal"
Option     "Disable" "false"
EndSection

Section "Device"
Identifier  "Default Device"
Driver      "fglrx"
Option     "Capabilities" "0x00000800"
Option     "TexturedVideoSync" "on"
Option     "OpenGLOverlay" "on"
BusID       "PCI:2:0:0"
EndSection

Section "Device"
Identifier  "amdcccle-Device[2]-0"
Driver      "fglrx"
Option     "Monitor-LCD" "0-LCD"
BusID       "PCI:2:0:0"
EndSection

Section "Screen"
Identifier "Default Screen"
DefaultDepth     24
EndSection

Section "Screen"
Identifier "amdcccle-Screen[2]-0"
Device     "amdcccle-Device[2]-0"
DefaultDepth     24
SubSection "Display"
Viewport   0 0
Depth     24
EndSubSection
EndSection

Al 3° comando mi da questo output:
Code: [Select]
failed to set textured video sync
Using /etc/X11/xorg.conf
Saved back-up to /etc/X11/xorg.conf.fglrx-11
« : November 16, 2009, 01:47:18 pm Reloweb »

Re: Dell Studio 1557
« #10 : November 19, 2009, 02:35:48 pm »

Se tolgo i driver fglrx i film si vedono correttamente ma ovviamente compiz non funziona...
Re: Dell Studio 1557
« #11 : November 22, 2009, 10:02:01 pm »

Se tolgo i driver fglrx i film si vedono correttamente ma ovviamente compiz non funziona...

Ma stai usando Karmic?  :?:
Re: Dell Studio 1557
« #12 : November 22, 2009, 10:39:42 pm »

Si.
Ho provato anche la versione precedente ovvero jaunty ma il problema è lo stesso.
Re: Dell Studio 1557
« #13 : November 24, 2009, 03:06:20 pm »

Si.
Ho provato anche la versione precedente ovvero jaunty ma il problema è lo stesso.

Ma il modello della tua scheda di preciso qual è? I driver da dove li hai installati? Secondo me - al momento - conviene comunque rimanere su Jaunty o al massimo cambiare distro. Karmic è altamente instabile e piena di bug. Comunque il tuo xorg.conf è stato autogenerato?
Re: Dell Studio 1557
« #14 : November 24, 2009, 03:19:00 pm »

Si.
Comunque su Jaunty fa la stessa cosa. La scheda video è una ATI Mobility HD 4570.

EDIT: Mi sa che è un bug dei driver fglrx: https://bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/303697
« : November 24, 2009, 04:06:10 pm Reloweb »

: [1] 2
You are here: Sky ForumHardwareComputerPortatiliDell Studio 1557
: