Leggi gli ultimi interventi sul forum
 

Show Posts

* Messages | Topics | Attachments

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - skydiamond

Pages: [1] 2 3 ... 56
1
Telefonia / Re: Informazioni utili android MTK6589
« on: August 24, 2013, 04:53:58 pm »

6
Linux / Re: Fedora 13 e VIA Technologies, Inc. VT1708/A [Azalia HDAC]
« on: November 26, 2011, 12:03:57 am »
Quote
I have found that the problem is the way the newer Linux kernels use ACPI to
enumerate all the PCI host bridges, and part of the host bridge description is
the “_CRS” (current resource settings) property, which lists the address space
used by the bridge.

I found this information here:
http://article.gmane.org/gmane.linux.kernel/947909

I have added 'pci=use_crs' as a kernel boot parameter on my system and this has
resolved the issue. I now have sound.


[greg@halfway ~]$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: VT82xx [HDA VIA VT82xx], device 0: ALC883 Analog [ALC883 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: VT82xx [HDA VIA VT82xx], device 1: ALC883 Digital [ALC883 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


https://bugs.mageia.org/show_bug.cgi?id=1651

DEBIAN: http://kmuto.jp/debian/hcl/VIA/Chrome9+HC+IGP/

ALSA e pci=use_crs --> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/662299

Code: [Select]
I took a backup of /etc/default/grub to /root/etc_default_grub_backup

then

opened the file /etc/default/grub with my favorite editor vi.

find the line

      GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

modify it like

      GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=use_crs"

save the file (/etc/default/grub)

after saving the file I ran update-grub like

sudo update-grub


8
Internet e news / I filtri di TeleTu su Megaupload
« on: September 10, 2011, 06:29:40 pm »
Adesso sembra che TeleTu abbia colpito con i filtri su qualsiasi cosa riguardi MegaUpload.com. Come anche un utente del forum di Hwupgrade ha scritto pare che adesso vengano bloccate anche tutte le ricerche su Google che abbiano quel dominio incorporato.  :'(

Io ho riscontrato anche problemi cercando con Google le parole chiave "TeleTu" e simili per aggirare il blocco. Mi sembra di vivere in Cina!

Sto testando tramite PROXY prendendoli da queste liste e pare che il problema sia proprio un filtro TeleTu:



9
Linux / Re: Fedora 13 e VIA Technologies, Inc. VT1708/A [Azalia HDAC]
« on: July 16, 2011, 05:34:48 pm »
Check del sistema audio

Prima di tutto andiamo a controllare le informazioni sul nostro sistema audio. Un comando immediato per verificare il riconoscimento di una scheda audio può essere:

Code: [Select]
aplay -l
Poi possiamo generare anche un file molto dettagliato con alsa-info che produrrà un file di informazioni salvato in /tmp. Questo file contiene un riassunto completo di tutto ciò che il sistema operativo vede sulla nostra macchina:

Code: [Select]
upload=true&script=true&cardinfo=
!!################################
!!ALSA Information Script v 0.4.60
!!################################

!!Script ran on: Sat Jul 16 15:26:49 UTC 2011


!!Linux Distribution
!!------------------

Fedora release 13 (Goddard) Fedora release 13 (Goddard) Fedora release 13 (Goddard) Fedora release 13 (Goddard)


!!DMI Information
!!---------------

Manufacturer:      MICRO-STAR INTERNATIONAL CO., LTD
Product Name:      MS-7253
Product Version:   1.0


!!Kernel Information
!!------------------

Kernel release:    2.6.34.9-69.fc13.i686
Operating System:  GNU/Linux
Architecture:      i686
Processor:         i686
SMP Enabled:       Yes


!!ALSA Version
!!------------

Driver version:     1.0.22.1
Library version:   
Utilities version:  1.0.23


!!Loaded ALSA modules
!!-------------------



!!Sound Servers on this system
!!----------------------------

Pulseaudio:
      Installed - Yes (/usr/bin/pulseaudio)
      Running - Yes

Jack:
      Installed - Yes (/usr/bin/jackd)
      Running - No


!!Soundcards recognised by ALSA
!!-----------------------------

--- no soundcards ---


!!PCI Soundcards installed in the system
!!--------------------------------------

80:01.0 Audio device: VIA Technologies, Inc. VT1708/A [Azalia HDAC] (VIA High Definition Audio Controller) (rev 10)


!!Advanced information - PCI Vendor/Device/Subsystem ID's
!!--------------------------------------------------------

80:01.0 0403: 1106:3288 (rev 10)
Subsystem: 1462:7253


!!Loaded sound module options
!!--------------------------


!!ALSA Device nodes
!!-----------------

crw-rw----+ 1 root audio 116, 3 Jul 16 17:15 /dev/snd/seq
crw-rw----+ 1 root audio 116, 2 Jul 16 17:15 /dev/snd/timer


!!ALSA configuration files
!!------------------------

!!System wide config file (/etc/asound.conf)

#
# Place your global alsa-lib configuration here...
#

@hooks [
{
func load
files [
"/etc/alsa/pulse-default.conf"
]
errors false
}
]


!!Aplay/Arecord output
!!------------

APLAY

aplay: device_list:235: no soundcards found...

ARECORD

arecord: device_list:235: no soundcards found...

!!Amixer output
!!-------------


!!Alsactl output
!!-------------

--startcollapse--
--endcollapse--


!!All Loaded Modules
!!------------------

Module
via
drm
ip6t_REJECT
nf_conntrack_ipv6
ip6table_filter
ip6_tables
ipv6
fuse
uinput
snd_hda_intel
snd_hda_codec
snd_hwdep
snd_seq
snd_seq_device
snd_pcm
snd_timer
i2c_viapro
i2c_core
ndiswrapper
snd
soundcore
snd_page_alloc
via_rhine
k8temp
mii
ppdev
parport_pc
parport
microcode
pata_acpi
ata_generic
sata_via
pata_via


!!ALSA/HDA dmesg
!!------------------

[<f8633c02>] (io_irq_isr+0x0/0x3d [ndiswrapper])
HDA Intel 0000:80:01.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
------------[ cut here ]------------
--
Hardware name: MS-7253
Modules linked in: snd_hda_intel(+) snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm snd_timer i2c_viapro i2c_core ndiswrapper(+) snd soundcore snd_page_alloc via_rhine k8temp mii ppdev parport_pc parport microcode pata_acpi ata_generic sata_via pata_via
Pid: 568, comm: modprobe Tainted: P           2.6.34.9-69.fc13.i686 #1
--
 [<c05ba296>] pci_ioremap_bar+0x2c/0x5b
 [<f889c1d1>] azx_probe+0x3bd/0xa14 [snd_hda_intel]
 [<c0515759>] ? sysfs_addrm_finish+0x1b/0x99
--
 [<c0451a6c>] ? __blocking_notifier_call_chain+0x45/0x51
 [<f88b2000>] ? alsa_card_azx_init+0x0/0x19 [snd_hda_intel]
 [<f88b2017>] alsa_card_azx_init+0x17/0x19 [snd_hda_intel]
 [<c0401143>] do_one_initcall+0x51/0x13f
--
---[ end trace c1346ebdf695f7f1 ]---
ALSA sound/pci/hda/hda_intel.c:2491: ioremap error
HDA Intel 0000:80:01.0: PCI INT A disabled
irq event 18: bogus return value f4e1d508



Un altro comando utile è lsmod per verificare la presenza dei moduli e il loro funzionamento. Per la scheda in questione il modulo dovrebbe essere snd_hda_intel.

Procedere per tentativi

Ho cercato per un buon periodo di tempo una soluzione possibile al problema. Un punto di partenza è ALSA e per capire come agire ho iniziato a controllare la disponibilità dei driver ALSA offerti da Fedora.

Alla fine sono arrivato a tentare diverse strada ma forse quella più promettente passa dalla ricompilazione di ALSA e all'installazione dell'ultima versione disponibile. Per farlo servono i moduli kernel-devel e ncurses-devel (compresi gli strumenti di base per la compilazione come make, gcc e patch). Serve anche  alsa-lib-devel.

Ho quindi seguito questa guida del wiki di Ubuntu che dovrebbe comunque andare bene anche per il caso in questione.


Configuring the audio and updating ALSA for Fedora 13

10
Linux / Fedora 13 e VIA Technologies, Inc. VT1708/A [Azalia HDAC]
« on: July 15, 2011, 05:01:08 pm »
Vediamo come far funzionare questa scheda audio (VIA Technologies, Inc. VT1708/A [Azalia HDAC]) su Fedora 13.

Informazioni di base sul sistema operativo in uso:
Code: [Select]
Linux 2.6.34.9-69.fc13.i686 #1 SMP Tue May 3 09:20:30 UTC 2011 i686 i386 GNU/Linux
Code: [Select]
# lspci -vvnn | grep -A10 Audio                                                                                                               
80:01.0 Audio device [0403]: VIA Technologies, Inc. VT1708/A [Azalia HDAC] (VIA High Definition Audio Controller) [1106:3288] (rev 10)                       
        Subsystem: Micro-Star International Co., Ltd. Device [1462:7253]                                                                                     
        Control: I/O- Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-                                               
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Interrupt: pin A routed to IRQ 17
        Region 0: Memory at <ignored> (64-bit, non-prefetchable)
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [60] MSI: Enable- Count=1/1 Maskable- 64bit+
                Address: 0000000000000000  Data: 0000

Code: [Select]
# lsmod | grep snd
snd_hda_intel          19887  0
snd_hda_codec          70924  1 snd_hda_intel
snd_hwdep               4860  1 snd_hda_codec
snd_seq                42775  0
snd_seq_device          5035  1 snd_seq
snd_pcm                62005  2 snd_hda_intel,snd_hda_codec
snd_timer              15391  2 snd_seq,snd_pcm
snd                    46603  7 snd_hda_intel,snd_hda_codec,snd_hwdep,snd_seq,snd_seq_device,snd_pcm,snd_timer
soundcore               4934  1 snd
snd_page_alloc          6033  2 snd_hda_intel,snd_pcm

Errore dmesg:
Code: [Select]
ALSA sound/pci/hda/hda_intel.c:2491: ioremap error

11
Videogames / Configurare Batman Arkham Asylum su Windows 7
« on: June 15, 2011, 10:33:19 pm »
Requisiti minimi:
* OPERATING SYSTEM: Microsoft Windows XP or Vista
* CPU: Intel Pentium 4 3GHz or AMD Athlon 64 3500 +
* RAM: 1GB for Windows XP 2GB for Windows Vista
* GRAPHICS: nVidia 6600 or ATI 1300
* SOUND: Microsoft Windows XP / Vista compatible sound card (100% DirectX 9.0c-compatible)
* DVD-ROM: Quad-speed (4x) DVD-ROM drive
* HARD DRIVE: 9GB free disk space

Prima di tutto installiamo Nvidia Physix e il gioco. Poi scarichiamo la patch 1.1 e installiamola. Una volta fatto ciò assicuriamoci di avere il gioco in italiano e se così non fosse settiamo la lingua direttamente dal file di configurazione che si trova su Documenti/Eidos/Batman Arkham Asylum/Bmgame/Config/Usergame.ini. Apriamo il file e settiamo language=ita.

Poi andate su Giochi (vedi immagine allegata) e cliccate con il pulsante destro l'icona selezionando "Finestra d'avvio". Da qui potrete andare a modificare i settaggi video. Fatto ciò vi consiglio di provare un Test benchmark sul gioco stesso da un qualsiasi punto di salvataggio. Dovrebbe funzionare tutto.



12
Sistemi operativi e programmi / Re: 69 Script-Fu per GIMP
« on: February 26, 2011, 12:45:33 pm »
Ho rimesso l'archivio online (che già aveva più di 4000 downloads). Il vecchio archivio era corrotto e non conteneva tutti gli script.  :-E

13
Javascript / Random String function
« on: February 13, 2011, 04:48:37 pm »
Un'utile funzione che consente di generare delle stringhe di lunghezza data in modo casuale.

Code: (javascript) [Select]
function randomString(lunghezza)
{
var chars = "0123456789ABCDEFGHIJKLMNOPQRSTUVWXTZabcdefghiklmnopqrstuvwxyz";
var string_length = lunghezza;
var randomstring = '';
for (var i=0; i<string_length; i++) {
var rnum = Math.floor(Math.random() * chars.length);
randomstring += chars.substring(rnum,rnum+1);
}
return randomstring;
}

14
Presentazioni / Re: ciao
« on: February 12, 2011, 11:55:00 am »
Benvenuto!  ^-^

15
Presentazioni / Re: ciao a tutti...
« on: February 10, 2011, 11:48:02 am »
Già attivato.  8)

P.S.
Contattami quando puoi.  ;)

Pages: [1] 2 3 ... 56